Catalyst telepítése

From Manjaro Linux
Jump to: navigation, search

Az AMD/ATI videokártyával rendelkezőknek választani kell az AMD saját drivere (catalyst) és a nyílt forráskódú (xf86-video-ati) driver között. Ez a cikk a AMD driveréről szól.

Az AMD Linux rendszerekre készült driverét a catalyst-nak hivják, korábban fglrx -nek (FireGL and Radeon X). nevezték. Csak a csomag neve változott meg, a kernel modul neve az ismét az eredeti fglrx.ko. A cikkben az fglrx hivatkozás mindig a kernel modulra vonatkozik és nem a csomagra.

2012 augusztusától a bináris csomag használata az ajánlott. Jelenleg a csomag elérhető a [basis] tárolóban. Az elmúlt időszakban a Catalyst_legacy driverek kikerültek a támogatásból, a Xorg-Server 1.13 verziókkal való kompatibilitási problémák miatt. Mindkét zárt drivert el kellett távolítanunk egy kis időre, a Xorg-Server 1.14 sorozatára váltásig.

A rendszer előkészítése a Catalyst Driver telepítéséhez

Először frissíteni kell a rendszert, hogy telepíthesd a Catalyst drivert. Ehhez a terminálban a következő parancsot kell kiadnod:

sudo pacman -Syyuu mhwd-db-catalyst


Ha kész van telepítheted a Catalyst drivert.


Catalyst driver telepítése

Az előkészítés után a következő parancs automatikusan kiválasztja és telepíti a megfelelő Catalyst drivert:

sudo mhwd -a pci nonfree 0300

A telepítés után indítsd újra a rendszert a változtatás érvényesítéséhez.

Hiba elhárítás

conflicting dependencies (ütköző függőségek)

Error: failed to prepare transaction (conflicting dependencies)

xf86-video-ati and catalyst-server are in conflict (xorg-server<1.14.0)


A Catalyst- server nem az összes nyílit drivert támogatja. Ezért távolítsd el őket a következő paranccsal:

 sudo mhwd -r pci video-ati

Néhány csomagot neked kell eltávolítani a pacmannal ezt a következő paranccsal teheted meg:

 sudo pacman -Rs <pkg-name>